Would you like to react to this message? Create an account in a few clicks or log in to continue.

Crafting Bug - enhancing a ring with +4 Dex or +9 spellcraft

Go down

Crafting Bug - enhancing a ring with +4 Dex or +9 spellcraft Empty Crafting Bug - enhancing a ring with +4 Dex or +9 spellcraft

Post by daveyeisley on Sun May 14, 2017 11:53 am

Please be aware that there is currently a bug that is eating rings when you try to enchant them with the properties listed in the subject of this post.

The issue may actually affect *all* commands for enchanting rings, but obviously I don't have time to test that, I just wanted to point out that the issue may not be restricted to those 2 properties, but it *does* seem to be restricted to rings.

This was discovered by Grudgebringer, when they lost 3 separate rings after paying the XP and gold. I got the XP and gold refunded, and was able to use some creative DM commands to give a reasonable facsimile of the desired end results, so for now they are all set.

I have duplicated the behavior on multiple characters using multiple different rings as the base item (ring of regeneration (+2), blood ring, pure metal ring, and silver ring).

What I have observed, is that it appears after the ;;mi empower command is used, the game creates a new ring and adds it to the players inventory. This is where the problem seems to occur, because with other items that do not stack like rings do, you would have two distinct items, and then the script zaps the original item. With the rings, because they stack, you actually see the original ring becomes a stack of 2 rings, and then the whole stack gets zapped by the script. At least that was what I seemed to observe.

I tested a workaround... to have the original ring inside a container when I used the select tool and entered the empower commend, and this worked OK for me on Crideas... the ring was upgraded, and did not get removed (and I also did not end up with 2 copies).

However, after that I tried to duplicate the original issue again... upgrading a ring that was *not* in a container.... and it still worked fine. So I am not sure about my theory.
Ludicrous Level
Ludicrous Level

. : Dungeon Master
Male Number of posts : 6926
Age : 43
Location : Watching Aenea from my Inner Sanctum on the surface of Sharlo, Aenea's Silver Moon
Main Character : Dave's List of PCs
NWN Username : Dave Yeisley
DM Name : Dungeon Master Mythgar
Time Zone : GMT - 5:00
. : Crafting Bug - enhancing a ring with +4 Dex or +9 spellcraft Forum_donor
Registration date : 2008-06-03

Back to top Go down

Back to top

- Similar topics

Permissions in this forum:
You cannot reply to topics in this forum